use strict;
my $str = '/sell 2000 USDT @ 5.56 111.222.333-44 +123456789 mail@example.com
/sell 2000 USDT @ 5.56 111.222.333-44 +123456789';
my $regex = qr/^/ # start of string and /
(?P<operation>buy|sell) #buy or sell
\s+ # 1+ whitespaces
(?P<amount>\d+) # 1+ digits
\s+ # 1+ whitespaces
(?P<network>\S+) # 1+ non-whitespaces
\s+ @ \s+ # 1+ whitespaces, @, 1+ whitespaces
(?P<rate>\S+) # 1+ non-whitespaces
\s+ # 1+ whitespaces
(?P<legal>\S+) # 1+ non-whitespaces
\s+ # 1+ whitespaces
(?P<cellphone>\+?\d(?:\s?\d)+) # optional +, digits with possible one whitespace in between each
(?: # non-capturing group start:
\s+ (?P<email>[^\s@]+@\S+) # 1+ whitespaces, email
)? # non-capturing group end, optional due to ?
$ # end of string/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}