# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^/ # start of string and /
(?P<operation>buy|sell) #buy or sell
\s+ # 1+ whitespaces
(?P<amount>\d+) # 1+ digits
\s+ # 1+ whitespaces
(?P<network>\S+) # 1+ non-whitespaces
\s+ @ \s+ # 1+ whitespaces, @, 1+ whitespaces
(?P<rate>\S+) # 1+ non-whitespaces
\s+ # 1+ whitespaces
(?P<legal>\S+) # 1+ non-whitespaces
\s+ # 1+ whitespaces
(?P<cellphone>\+?\d(?:\s?\d)+) # optional +, digits with possible one whitespace in between each
(?: # non-capturing group start:
\s+ (?P<email>[^\s@]+@\S+) # 1+ whitespaces, email
)? # non-capturing group end, optional due to ?
$ # end of string
"""
test_str = ("/sell 2000 USDT @ 5.56 111.222.333-44 +123456789 mail@example.com\n\n"
"/sell 2000 USDT @ 5.56 111.222.333-44 +123456789")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.