#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\n\n+(^\s*)" & @CRLF & _
""
Local $sString = "row 1" & @CRLF & _
"row 2" & @CRLF & _
"" & @CRLF & _
"row 1" & @CRLF & _
"" & @CRLF & _
"row 1" & @CRLF & _
"row 2" & @CRLF & _
"row 3" & @CRLF & _
"row 4" & @CRLF & _
"row 5" & @CRLF & _
"row 6" & @CRLF & _
"" & @CRLF & _
"row 1" & @CRLF & _
"row 2" & @CRLF & _
"row 3" & @CRLF & _
"row 4" & @CRLF & _
"row 5" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")