re = /\n\n+(^\s*)
/m
str = 'row 1
row 2
row 1
row 1
row 2
row 3
row 4
row 5
row 6
row 1
row 2
row 3
row 4
row 5
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end