const regex = /\n\n+(^\s*)
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\n\\n+(^\\s*)
', 'gm')
const str = `row 1
row 2
row 1
row 1
row 2
row 3
row 4
row 5
row 6
row 1
row 2
row 3
row 4
row 5
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}