$re = '/\n\n+(^\s*)
/m';
$str = 'row 1
row 2
row 1
row 1
row 2
row 3
row 4
row 5
row 6
row 1
row 2
row 3
row 4
row 5
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);