#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\d+"
Local $sString = "[abc789-def-000]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)