package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+`)
var str = `[abc789-def-000]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}