const regex = new RegExp('\\d+', 'g')
const str = `[abc789-def-000]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);