use strict;
my $str = '[abc789-def-000]';
my $regex = qr/\d+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";