#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\((?:\((?:\((?:\([^()]*\)|[^()])*\)|[^()])*\)|[^()])*\)[^(),]*)|,"
Local $sString = "x@x,a,b,c,d(some(other,arg2),p)@yyy"
Local $sSubst = "\1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)