re = /(\((?:\((?:\((?:\([^()]*\)|[^()])*\)|[^()])*\)|[^()])*\)[^(),]*)|,/
str = 'x@x,a,b,c,d(some(other,arg2),p)@yyy'
subst = '\\1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result