$re = '/(\((?:\((?:\((?:\([^()]*\)|[^()])*\)|[^()])*\)|[^()])*\)[^(),]*)|,/';
$str = 'x@x,a,b,c,d(some(other,arg2),p)@yyy';
$subst = "\1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;