// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\((?:\((?:\((?:\([^()]*\)|[^()])*\)|[^()])*\)|[^()])*\)[^(),]*)|,").unwrap();
let string = "x@x,a,b,c,d(some(other,arg2),p)@yyy";
let substitution = "\\1\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}