#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=(?:.*\d){3})(?=(?:.*[a-zA-Z]){1})^[a-zA-Z\d]*$"
Local $sString = "123d" & @CRLF & _
"f311" & @CRLF & _
"12d3" & @CRLF & _
"99A9A" & @CRLF & _
"1234" & @CRLF & _
"aaaa" & @CRLF & _
"a1aa" & @CRLF & _
"a11a" & @CRLF & _
"1_11"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")