import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(?:.*\\d){3})(?=(?:.*[a-zA-Z]){1})^[a-zA-Z\\d]*$";
final String string = "123d\n"
+ "f311\n"
+ "12d3\n"
+ "99A9A\n"
+ "1234\n"
+ "aaaa\n"
+ "a1aa\n"
+ "a11a\n"
+ "1_11";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}