const regex = /(?=(?:.*\d){3})(?=(?:.*[a-zA-Z]){1})^[a-zA-Z\d]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(?:.*\\d){3})(?=(?:.*[a-zA-Z]){1})^[a-zA-Z\\d]*$', 'gm')
const str = `123d
f311
12d3
99A9A
1234
aaaa
a1aa
a11a
1_11`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}