re = /(?=(?:.*\d){3})(?=(?:.*[a-zA-Z]){1})^[a-zA-Z\d]*$/m
str = '123d
f311
12d3
99A9A
1234
aaaa
a1aa
a11a
1_11'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end