using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?P<X>\S.*?)(?:, (?P=X))+)";
string input = @"[1, 2, 3, 1, 2, 3, 1, 2, 3, 2, 5, 2, 5]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}