re = /((?P<X>\S.*?)(?:, (?P=X))+)/m
str = '[1, 2, 3, 1, 2, 3, 1, 2, 3, 2, 5, 2, 5]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end