package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?P<X>\S.*?)(?:, (?P=X))+)`)
var str = `[1, 2, 3, 1, 2, 3, 1, 2, 3, 2, 5, 2, 5]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}