$re = '/((?P<X>\S.*?)(?:, (?P=X))+)/m';
$str = '[1, 2, 3, 1, 2, 3, 1, 2, 3, 2, 5, 2, 5]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);