#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Match"
Local $sString = "Ⓜⓐⓣⓒⓗ" & @CRLF & _
"🅜🅐🅣🅒🅗" & @CRLF & _
"Match" & @CRLF & _
"𝐌𝐚𝐭𝐜𝐡" & @CRLF & _
"𝕸𝖆𝖙𝖈𝖍" & @CRLF & _
"𝑴𝒂𝒕𝒄𝒉" & @CRLF & _
"𝓜𝓪𝓽𝓬𝓱" & @CRLF & _
"𝕄𝕒𝕥𝕔𝕙" & @CRLF & _
"𝙼𝚊𝚝𝚌𝚑" & @CRLF & _
"𝖬𝖺𝗍𝖼𝗁" & @CRLF & _
"𝗠𝗮𝘁𝗰𝗵" & @CRLF & _
"𝙈𝙖𝙩𝙘𝙝" & @CRLF & _
"𝘔𝘢𝘵𝘤𝘩" & @CRLF & _
"⒨⒜⒯⒞⒣" & @CRLF & _
"🇲🇦🇹🇨🇭" & @CRLF & _
"🄼🄰🅃🄲🄷" & @CRLF & _
"🅼🅰🆃🅲🅷 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")