import Foundation
let pattern = #"Match"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Ⓜⓐⓣⓒⓗ
🅜🅐🅣🅒🅗
Match
𝐌𝐚𝐭𝐜𝐡
𝕸𝖆𝖙𝖈𝖍
𝑴𝒂𝒕𝒄𝒉
𝓜𝓪𝓽𝓬𝓱
𝕄𝕒𝕥𝕔𝕙
𝙼𝚊𝚝𝚌𝚑
𝖬𝖺𝗍𝖼𝗁
𝗠𝗮𝘁𝗰𝗵
𝙈𝙖𝙩𝙘𝙝
𝘔𝘢𝘵𝘤𝘩
⒨⒜⒯⒞⒣
🇲🇦🇹🇨🇭
🄼🄰🅃🄲🄷
🅼🅰🆃🅲🅷
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)