import re
regex = re.compile(r"Match", flags=re.MULTILINE)
test_str = ("Ⓜⓐⓣⓒⓗ\n"
"🅜🅐🅣🅒🅗\n"
"Match\n"
"𝐌𝐚𝐭𝐜𝐡\n"
"𝕸𝖆𝖙𝖈𝖍\n"
"𝑴𝒂𝒕𝒄𝒉\n"
"𝓜𝓪𝓽𝓬𝓱\n"
"𝕄𝕒𝕥𝕔𝕙\n"
"𝙼𝚊𝚝𝚌𝚑\n"
"𝖬𝖺𝗍𝖼𝗁\n"
"𝗠𝗮𝘁𝗰𝗵\n"
"𝙈𝙖𝙩𝙘𝙝\n"
"𝘔𝘢𝘵𝘤𝘩\n"
"⒨⒜⒯⒞⒣\n"
"🇲🇦🇹🇨🇭\n"
"🄼🄰🅃🄲🄷\n"
"🅼🅰🆃🅲🅷 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")