#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\/[^\W_]+(?:\*|\/\*)?|\*)+$|^\/\*?$"
Local $sString = "# Should match:" & @CRLF & _
"/" & @CRLF & _
"/*" & @CRLF & _
"/abc" & @CRLF & _
"/abc*" & @CRLF & _
"/abc/*" & @CRLF & _
"/abc/def" & @CRLF & _
"/abc/def/xyz" & @CRLF & _
"/abc/def/*" & @CRLF & _
"" & @CRLF & _
"# Should not match:" & @CRLF & _
"/abc/" & @CRLF & _
"/abc*/" & @CRLF & _
"/abc/def*" & @CRLF & _
"/abc*/def" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")