$re = '/^(?:\/[^\W_]+(?:\*|\/\*)?|\*)+$|^\/\*?$/m';
$str = '# Should match:
/
/*
/abc
/abc*
/abc/*
/abc/def
/abc/def/xyz
/abc/def/*
# Should not match:
/abc/
/abc*/
/abc/def*
/abc*/def
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);