re = /^(?:\/[^\W_]+(?:\*|\/\*)?|\*)+$|^\/\*?$/m
str = '# Should match:
/
/*
/abc
/abc*
/abc/*
/abc/def
/abc/def/xyz
/abc/def/*
# Should not match:
/abc/
/abc*/
/abc/def*
/abc*/def
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end