package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\/[^\W_]+(?:\*|\/\*)?|\*)+$|^\/\*?$`)
var str = `# Should match:
/
/*
/abc
/abc*
/abc/*
/abc/def
/abc/def/xyz
/abc/def/*
# Should not match:
/abc/
/abc*/
/abc/def*
/abc*/def
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}