#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![^_:]*_)[a-z][\w:-]*$"
Local $sString = "Valid" & @CRLF & _
"hello123" & @CRLF & _
"hello:123" & @CRLF & _
"hello-hello" & @CRLF & _
"hello:123-hello_345" & @CRLF & _
"hello-1:hell_world_123" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"**Invalid patterns**" & @CRLF & _
"hello_123" & @CRLF & _
"hello-123_world" & @CRLF & _
"hello_123:world" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")