const regex = new RegExp('^(?![^_:]*_)[a-z][\\w:-]*$', 'gm')
const str = `Valid
hello123
hello:123
hello-hello
hello:123-hello_345
hello-1:hell_world_123
**Invalid patterns**
hello_123
hello-123_world
hello_123:world
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}