import re
regex = re.compile(r"^(?![^_:]*_)[a-z][\w:-]*$", flags=re.MULTILINE)
test_str = ("Valid\n"
"hello123\n"
"hello:123\n"
"hello-hello\n"
"hello:123-hello_345\n"
"hello-1:hell_world_123\n\n\n"
"**Invalid patterns**\n"
"hello_123\n"
"hello-123_world\n"
"hello_123:world\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")