import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![^_:]*_)[a-z][\\w:-]*$";
final String string = "Valid\n"
+ "hello123\n"
+ "hello:123\n"
+ "hello-hello\n"
+ "hello:123-hello_345\n"
+ "hello-1:hell_world_123\n\n\n"
+ "**Invalid patterns**\n"
+ "hello_123\n"
+ "hello-123_world\n"
+ "hello_123:world\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}