#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+(?:\.\d+)?)-(\d+(?:\.\d+)?)"
Local $sString = "some foo text" & @CRLF & _
"some foo" & @CRLF & _
"1.00-2.00" & @CRLF & _
"3.21-1.23" & @CRLF & _
"2.12-2.12" & @CRLF & _
"1-2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")