$re = '/(\d+(?:\.\d+)?)-(\d+(?:\.\d+)?)/m';
$str = 'some foo text
some foo
1.00-2.00
3.21-1.23
2.12-2.12
1-2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);