import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+(?:\\.\\d+)?)-(\\d+(?:\\.\\d+)?)";
final String string = "some foo text\n"
+ "some foo\n"
+ "1.00-2.00\n"
+ "3.21-1.23\n"
+ "2.12-2.12\n"
+ "1-2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}