re = /(\d+(?:\.\d+)?)-(\d+(?:\.\d+)?)/m
str = 'some foo text
some foo
1.00-2.00
3.21-1.23
2.12-2.12
1-2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end