using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=class="")\s?btn\s?(btn-)?(mini|small|large)?\s?(?="")";
string input = @"<button class=""btn btn-mini"" />
<button class=""btn btn-small"" />
<button class=""btn btn-large""/>
<button class=""btn""/>
<button class=""btn ""/>
<button class="" btn""/>
<button class=""btn btn-mini btn-primary"" />
<button class=""btn btn-small btn-success"" />
<button class=""btn btn-large btn-info""/>
<button class=""btn btn-error""/>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}