$re = '/(?<=class=")\s?btn\s?(btn-)?(mini|small|large)?\s?(?=")/';
$str = '<button class="btn btn-mini" />
<button class="btn btn-small" />
<button class="btn btn-large"/>
<button class="btn"/>
<button class="btn "/>
<button class=" btn"/>
<button class="btn btn-mini btn-primary" />
<button class="btn btn-small btn-success" />
<button class="btn btn-large btn-info"/>
<button class="btn btn-error"/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);