import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=class=\")\\s?btn\\s?(btn-)?(mini|small|large)?\\s?(?=\")";
final String string = "<button class=\"btn btn-mini\" />\n"
+ "<button class=\"btn btn-small\" />\n"
+ "<button class=\"btn btn-large\"/>\n"
+ "<button class=\"btn\"/>\n"
+ "<button class=\"btn \"/>\n"
+ "<button class=\" btn\"/>\n"
+ "<button class=\"btn btn-mini btn-primary\" />\n"
+ "<button class=\"btn btn-small btn-success\" />\n"
+ "<button class=\"btn btn-large btn-info\"/>\n"
+ "<button class=\"btn btn-error\"/>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}