#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*\bintegration\b.*)(?!.*\btest\b.*).*"
Local $sString = "integration, but include 'test'" & @CRLF & _
"integration, but include 'tes" & @CRLF & _
"integration, but include 'tests" & @CRLF & _
".integration.test.js" & @CRLF & _
".integration.tests.js"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")