$re = '/(?=.*\bintegration\b.*)(?!.*\btest\b.*).*/m';
$str = 'integration, but include \'test\'
integration, but include \'tes
integration, but include \'tests
.integration.test.js
.integration.tests.js';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);