import re
regex = re.compile(r"(?=.*\bintegration\b.*)(?!.*\btest\b.*).*", flags=re.MULTILINE)
test_str = ("integration, but include 'test'\n"
"integration, but include 'tes\n"
"integration, but include 'tests\n"
".integration.test.js\n"
".integration.tests.js")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")