const regex = /(?=.*\bintegration\b.*)(?!.*\btest\b.*).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*\\bintegration\\b.*)(?!.*\\btest\\b.*).*', 'gm')
const str = `integration, but include 'test'
integration, but include 'tes
integration, but include 'tests
.integration.test.js
.integration.tests.js`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}