import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:\\w+\\.)*(?:(?:\\w+)+))\\.(?:\\d\\.\\w+)$";
final String string = "items.very.nested.path\n"
+ "items.1.come.hhhh.asd\n"
+ "items.1.come.1\n"
+ "items.1.come.1.field\n"
+ "items.path.come.1.field\n"
+ "items.1.field";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}