$re = '/^((?:\w+\.)*(?:(?:\w+)+))\.(?:\d\.\w+)$/m';
$str = 'items.very.nested.path
items.1.come.hhhh.asd
items.1.come.1
items.1.come.1.field
items.path.come.1.field
items.1.field';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);