re = /^((?:\w+\.)*(?:(?:\w+)+))\.(?:\d\.\w+)$/m
str = 'items.very.nested.path
items.1.come.hhhh.asd
items.1.come.1
items.1.come.1.field
items.path.come.1.field
items.1.field'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end