using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Invoice ((?:[0-9]){8})";
string input = @"THIS IS AN EXAMPLES OF Invoice Email Subject sample
Harmonie Mutuelle - Invoice 1234567890123456
123 WDD2052041F133125 - CORRECT VIN
44 WDD 169 007-1J-236589 - ALSO CORRECT VIN
1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 - INCORRECT VIN
AND THIS IS JUST CAPS TEXT FOR THE TEST
WDD2052041F133125
WDD 2052041F133125 - VIN WITH TAB
!! WDD2052041F133125
- TWO VINS CODES ONE BY ONE
W D - - - D 2 0 5 2---0 4 1 F-1 3-3125
- MULTIPLE DELIMITERS
X WDD
2052041F133125
- MULTILINE DELIMITERS
(WDD2052041F133125)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}