import Foundation
let pattern = #"Invoice ((?:[0-9]){8})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
THIS IS AN EXAMPLES OF Invoice Email Subject sample
Harmonie Mutuelle - Invoice 1234567890123456
123 WDD2052041F133125 - CORRECT VIN
44 WDD 169 007-1J-236589 - ALSO CORRECT VIN
1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 - INCORRECT VIN
AND THIS IS JUST CAPS TEXT FOR THE TEST
WDD2052041F133125
WDD 2052041F133125 - VIN WITH TAB
!! WDD2052041F133125
- TWO VINS CODES ONE BY ONE
W D - - - D 2 0 5 2---0 4 1 F-1 3-3125
- MULTIPLE DELIMITERS
X WDD
2052041F133125
- MULTILINE DELIMITERS
(WDD2052041F133125)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)