import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Invoice ((?:[0-9]){8})";
final String string = "THIS IS AN EXAMPLES OF Invoice Email Subject sample\n"
+ "Harmonie Mutuelle - Invoice 1234567890123456\n"
+ "123 WDD2052041F133125 - CORRECT VIN\n"
+ "44 WDD 169 007-1J-236589 - ALSO CORRECT VIN\n"
+ "1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 - INCORRECT VIN\n"
+ "AND THIS IS JUST CAPS TEXT FOR THE TEST\n"
+ "WDD2052041F133125\n"
+ "WDD 2052041F133125 - VIN WITH TAB\n"
+ "!! WDD2052041F133125\n"
+ "- TWO VINS CODES ONE BY ONE\n"
+ "W D - - - D 2 0 5 2---0 4 1 F-1 3-3125 \n"
+ "- MULTIPLE DELIMITERS\n"
+ "X WDD\n"
+ "2052041F133125\n"
+ "- MULTILINE DELIMITERS\n"
+ "(WDD2052041F133125)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}